ASUS TF300 Charger Magic

So here’s something. I realize that no one really cares, but I’m posting this as a public service to some intrepid internet traveler facing the same problem.

Yesterday I discovered that the charger for my ASUS tablet had suddenly quit working. It’s a typical liitle black block with a USB outlet, but when connected to the tablet (or its dock) it puts out 15V @ 1.2A (as opposed to the USB spec of 5V @ 500-900mA). I have all sorts of USB power adapters, but none that put out the voltage/current the tablet requires.

Soo… panic-stricken, I go online and order a replacement. A bit of Googling reveals that this is a fairly common issue which a number of people claim has a novel solution: Put the charger in the freezer. This supposedly resets some sort of thermal-overload breaker, returning the charger to working condition. (The charger in question is for the SL101 Series, TF101 Series, TF201 Series, TF300 Series, TF700 Series, and their docks.)

Dubious, but having nothing to lose, I put the charger in a Ziploc bag and place it in the freezer. Much to my surprise and delight…
It worked! Thanks interwebs!

It’s a catastrophe! (or is it?)

I love it when what at first appears to be a catastrophe turns out to be no big deal.

Earlier my power went out, just for a minute. Once it came back on I discovered an issue with my file server. It would power up briefly then shut down. It wasn’t even making it into POST, no beeps, no nuthin’. Immediately panic starts to set in as I imagine all of the expensive, time consuming, pain in the ass possibilities. I try it several more times, each with the same result. Then, after I got ahold of myself, I decided maybe it was the power supply, as that seemed the most likely culprit.

So… I retrieved my power supply tester, turned off the power supply, opened up the case and disconnected the 20-pin connector from the motherboard. I plug it into the tester, power it up, and it’s fine. Hmm…
must be the 4 pin connector for the CPU, that’s the only other line I can think of that might keep the computer from POST-ing. Again it tests as good.

Puzzled, I plug the connectors back in and give it another try. Just as before the power LED lights and the fans spin up, but this time, one short beep! Hallelujah! I punch it up on the KVM switch and see this message: CMOS Checksum error. Hmm… could the battery be dead? I pull the battery, grab my multi-meter, and sure enough, it’s dead. Completely, 100%, graveyard dead. Happily, I have a spare battery on hand. I replace the battery and it boots right up, happy as a clam.

Hooray for successful trouble-shooting (and a bit of luck). The “experts” on the internet seem to be split as to whether or not a dead CMOS battery can stop a computer from powering up. Some say yes, some say absolutely not. Well, I now know for a fact that it can. So, if you have a computer that powers up then right back down and isn’t giving any beep codes, test the power supply and the CMOS battery before letting visions of fried CPUs, dead motherboards, or bad RAM dance through your head.

What I want in a car “entertainment system”

I’ve been thinking about building a PC for use in the car for ages (most likely running some flavor of Linux). Gradually the market is catching up with my desires and it looks as if soon I may be able to buy exactly what I want “off the rack”. Here’s what I want:

1) A touchscreen interface that fits a double DIN dash opening. (common in many late model cars)
2) Provisions for (2) 3.5″ Hard drives. I want all of my Mp3’s in the car.
3) The ability to accept any cell phone’s SIM card and work with a “douche tooth” earpiece.
4) Obviously 3G/4G connectivity, Bluetooth, and WiFi.
5) GPS with turn by turn directions.
6) Alarm System

This is all I can come up with now. I’m sure I’ll be adding to the ‘wish list’ as time goes on.
Does anyone out there have any experience with, or opinions of, these type devices?
Share in the comments.

10 Years of searching for ET, curing cancer ‘n stuff

It’s just come to my attention that I first signed up with SETI@home on September 1, 1999. I did take some time (a few years, maybe; who knows?) off after they discontinued the original SETI@home and switched to the BOINC client. Anyway, during those first few years I completed 5,218 SETI classic workunits, donating 41,374 CPU-hours. Since switching over to the BOINC client I’ve earned over 900,000 credits split more or less evenly between SETI@home, Einstein@home and Rosetta@home. As a matter of fact I’m on pace to surpass 1,000,000 credits sometime in October. It really is quite remarkable to reflect upon. I first started crunching data for SETI with a Pentium 233 MMX with, I think, 128M of RAM (That’s 233 Mhz, kids). Now the slowest computer I’m running is a Pentium 4 2.8Ghz with 768M of RAM. Moore’s law, indeed!

If for some inexplicable reason you’d like to see my BOINC stats, you can do so here or here.

Spring Fever

Does the Spring Fever make one shop compulsively? If so, then that’s probably what I’ve got. In just the last two weeks I’ve bought:

5 new cycling caps (what the Hell, they’re cheap, right?)
1 “new” CPU (another 3.0G/512K/800Mhz Pentium 4)
&
Yet another video card (for a thus-far unsuccessful attempt to run CUDA on Kubuntu).

At least they’re all fairly small (<$50) purchases, so I guess it's not so bad. It’s not like I’m buying new bikes or fancy new wheelsets (yet).

That’s How They (USPS, UPS, DHL, FedEx, et al.) Get You (again)

Back on April 1st, I ordered a (warning: nerd content) serial to RJ-45 cable which I need to update the firmware on my new-to-me Belkin 8 port KVM.

Yesterday it still hadn’t come and the seller’s website was showing its status as “processing”, which would imply that it hadn’t shipped yet. Naturally I emailed them to ask what the deal was and, naturally, it arrived today. It just blows my mind how often that exact same scenario plays out.

I’m Handy!

This is another one of those “hopefully someone having the same problem comes across it and finds it useful” posts.

So my video card has taken to acting wonky, of late. Whenever I’d play a game (COD4 mainly) after a few minutes it would freeze up. My guess was that it was heat related, probably a bad fan on my SAPPHIRE Radeon X700PRO 256MB 128-bit GDDR3 PCI Express x16 Video Card. This was a great “bang for the buck” card when I bought it in August of 2005 and still fulfills my gaming needs just fine today, so I’d really rather not replace it, though I feared that would be necessary. Opening the case I find the fan barely turning at all and I know that I have my culprit.

The stock fan is a proprietary piece that I’m extremely unlikely to find a replacement for (and trust me, I looked), so I’m thinking I’m going to have to buy an third party cooling solution to replace the whole factory heatsink/fan assembly, which seems ridiculous, given the depreciated value of the card today. Before I start throwing money at this thing, I decide to see if it’s fixable. I pull the card out and find that the fan is secured to the heatsink by three very small Phillips-head screws. I get the screws out, remove the fan (which is very stiff and “draggy” and remove the sticker from the bottom covering its insides. Searching for suitable lube I decide upon Boeshield T-9. Developed by Boeing for Aerospace use, sold for cycling use, seems like just the ticket. A few drips later, the fan is spinning quite freely, so I put it all back together, reinstall it and BINGO! The temp never rises near the danger range the fan spins freely and all is (for now) well. And I can get back to the important business of “shooting melon fevers” in COD4.



The moral of this story: don’t give up on “bad” cooling fans. They can almost always be replaced, resurrected (cleaned and lubed) or “upgraded” to third party cooling solutions.

I Can’t Resist a Bargain

I’ve got a laptop that I’ve had for, I don’t know, maybe 7 years. Anyway, lately I’ve been thinking it’s probably time to upgrade the operating system from Windows 98 (I know! crazy, huh?). A while back I set it up to dual-boot with Kubuntu 8.04, and that really served to highlight just how dated Win98 is.

So, I’ve been seriously debating ditching 98 altogether and just running Linux, or possibly installing XP. Last week I was perusing eBay and came across a pretty sweet little IBM NetVista box for sale; 2Ghz P4, 512M of Ram, a $71 ‘Buy it now’ price (+$20 shipping) and best of all, it came with XP Pro installed. This set the wheels to turning;
I’ve got an XP Pro CD, I could use this computer’s activation key, install XP on the laptop, install Linux on the new ‘puter and add a new member to my computer minions, all for less than I would have paid to buy XP for the laptop (and with no “piracy” issues)!
Done, done, and done!
I just finished installing XP Pro on the laptop, activating it with Micro$oft, and updating it to SP3. The “new” NetVista is contentedly crunching numbers for BOINC, and I feel like a frugal demented genius… or something.

The Problem With Building Your Mother A Computer…

…is that you then become, by default, tech-support. My hair stands on end when she calls on the phone and says, “I’m having trouble with my computer”.

Recently she made that very call. Her computer was making a noise (which she couldn’t describe) and, more troublingly the motherboard’s protection software had popped up a warning “something about heat” just before it shut down. Let me just pause here to say, my mother is an amazing, extraordinarily intelligent woman. She doesn’t, however, know nor does she have any interest in knowing what makes her computer work.

Analyzing the facts at hand, I determined that the most likely culprit was the fan on the CPU heatsink. I pulled up the emailed invoice, checked the Intel website, and determine that it is still under warranty (two years old, 3 year warranty!)

I call Intel, hopeful that with the info from the invoice I can get a new heatsink on its way. No such luck, they need specific info from the fan and from the processor itself. Ok, this isn’t a huge problem, and I at least have jumped the first few hurdles with Intel and have a case number. When I handed the computer over to mom, I had nested all of the component’s boxes into the larger boxes and had her save them, so it shouldn’t take long to locate the CPU box and get the serial number and such… in theory. In reality, a few phone calls later, it’s obvious Mom isn’t going to find the box.

In a scene reminiscent of a 70’s disaster film, wherein the control tower talks the sweating passenger through the landing of a jumbo-jet, I (looking at photos and diagrams online) manage to talk my mother through removing the heatsink from her CPU. Jubilant with her success, she gets off the phone with me to call Intel.

Far too soon, my phone rings, they’re closed for the night.

The next evening, she calls Intel, everything goes swimmingly, and Diego (whom she was quite impressed with) assured her that the heatsink should be there in 2 – 5 days. She gives my email address to send the confirmation and tracking info to, as her computer is (obviously) down.

The tracking info comes shortly after midnight and it says that it was shipped next-day air. The next day I check the tracking status and discover that it was delivered at 9:30 AM! Just over 13 hours after she’d gotten off the phone with them!

So, I call Mom that evening and tell her to look on her porch for the package, then we repeat the control-tower, nervous non-pilot, reinstallation process.

I’d give anything for a picture of my mother’s face when she got it back together and it worked without a hitch. Just the joy in her voice was reward enough. She was (understandably) proud of herself, and I was proud of her. Graciously, she complimented me for doing such a good job talking her through it.

My lovely, amazing mother and Intel’s customer service both earn a resounding:

Crazy Greg's Seal of Approval

Blogger Beta Blues, Part III

Here’s the really crazy part of the whole sordid mess: At the same instant that I discovered that the importation process into WordPress was not going to work, and I began to curse Google/Blogger for raining on my parade; I smelled smoke.

Acrid, burning plastic-type smoke. As I sniffed the air, searching for the source, I saw smoke wafting out of the top of my file server, which promptly shut down. Pulling the cover off and peering inside, I wasn’t immediately able to find the source of the smoke, but there were traces of the thread-like soot that is characteristic of burning plastic scattered here and there inside the case. I disconnected the power, grabbed a flashlight, and searched for the culprit. Several minutes later, I found it. At the edge of the motherboard, hidden from view between a PCI card the edge of the case, two plastic jumpers had melted down and, evidently, caught fire.

Here’s the really, really crazy part: After I pulled the charred remnants of the jumpers off, I warily powered the computer back up… and it booted right up and ran (and continues to run) as though nothing had happened! Crazy! (And not exactly confidence-inspiring.)

Naturally, even though there’s absolutely no evidence of any involvement, I blame Blogger/Google.

Bastards!

More On (moron?) Western Digital

So, the other day I was blogging about my satisfaction with WD’s customer service, right? Well, as Paul Harvey would say, here’s the rest of the story.

They shipped the replacement via UPS second day air, it arrived on time and I happily prepared to install the new drive. One little problem, though. They had shipped me the wrong drive! This was immediately apparent, the replacement drive was a WD1600JB (EIDE interface); the drive it was replacing was a WD1600JS (SATA-II interface). After a bit of handwringing and grumbling, I called their customer service folks to inform them of the error. The girl I spoke with had a peculiar cadence and lilt to her voice that I found very difficult to understand (though nothing like the poor stuttering engineer from ATI I got tech support from a few years ago!), so I hung up not exactly sure what she had said, other than that they would email me a return shipping label and another drive would be on its way. A couple of days passed, no packages arrived, and the RMA information page on their website was still only showing the original shipment, so I called again. Amazingly, this time I got the same technician I had spoken with the first time, Grant. He seemed as mystified as I was that the drive hadn’t been shipped yet, made sure I had gotten the return shipping label, and assured me that the correct drive would be on its way immediately. It was, it arrived promptly 2 business days after finally being shipped, and so far it’s working just fine.

So, Western Digital has been downgraded from an enthusiastic “Crazy Greg’s Seal of Approval” to a qualified “CGSOA”.

And now you know the rest of the story.

Simultaneous Bad Luck and Good Luck (Geek Content)

So, I’ve just built up a new computer (yesterday). It rocks, and everything came together without a hitch. Until today that is. I awoke to this “click… click… click…” sound that seemed to coming from the direction of the new computer.

Closer investigation revealed that it was the computer, or, more specifically, one of the brand-spanking new 160G Western Digital SATA-II hard drives. Here’s the lucky part; it’s not the boot drive which I just spent much of the night installing software on, it’s “just” the scratch disc.

So, I go to WD’s website, it suggests I try starting the computer up with the data cable disconnected from that drive and seeing if it still clicks. I do, it does, bingo! Bad drive.

So, I call Western Digital, spend a little too much time on hold being force-fed bad jazz at an uncomfortable volume level, then finally get a guy on the line. I describe the sequence of events and he says “Yep, bad drive, we’ll need to replace that.”

The cool thing is: They have Advance Replacement. They ship the replacement to me, enter an authorization on my credit card, I ship the dead drive back (in their packaging) within thirty days and the authorization drops off.

I’ve always had good luck with WD drives (I had 4 providing years of trouble free service in other computers when I got the new comp.) A bad drive happens every now and then, I suppose, and at least they make the replacement process as painless as possible.

Western Digital gets Crazy Greg’s Seal of Approval!